FraudmarcCE Frontend Not Displaying DMARC Reports


#1

I’ve recently setup FraudmarcCE in AWS. Aggregate reports have been processed by the lambda receive and process functions and I see data written to PostgreSql, but nothing displays when connecting to localhost:7489 or ip_address:7489. It has been only a day with 300 aggregate report emails already processed but do we need to wait a couple more days? Here’s a screenshot of the frontend where it just circles. Thanks.


#2

I think this is because you only have one day’s data. The line chart requires at least two data points to process, which blocks the whole rendering of the front end. The Fraudmarc app seems to have fixed this bug. For the first day of process it just skip showing the volume distribution over time.


#3

Ok, I’ll wait a couple more days. Thanks.


#4

There has been a few thousand aggregate report emails processed over the past two days and it’s still circling. Not sure if I need to wait a couple more days. Also, I’ve reinstalled the docker frontend with the same results. Is there anything else I can check on my end. Thanks.


#5

I am aware of several organizations that use Fraudmarc CE without issue so this problem is related to washingtonpost.com’s unique environment but we will help troubleshoot and support your installation. Email or directly message us to schedule a remote access session or a screen share session.


#6

I’m having a similar issue. On my local machine the tool works great. However I tried to re-create it on AWS and even though I’m using the exact same content from my local machine, the web url for the EC2 just spins and spins. I’ve double and tripled checked firewall/SGs. The EC2 can connect to RDS without issue. Any ideas or suggestions?


#7

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#8

@jeremyg Glad to know it’s working well locally as that’s the intended and secure way to use CE. What’s your purpose for changing?


#9

I’d like to make results available to my colleagues for their research and work. Better than shoulder surfing :wink:


#10

@bagitte Fraudmarc CE is on dockerhub so you can simply:
docker run fraudmarc/fraudmarc-ce

It’s a super compact image weighing un under 4.5mb!


#11

I think I tried that initially but had the same results. Will try that again. Thanks.


#13

Looks like the connection is refused when accessing it over the network via IP. When connecting to the the frontend via an IP address on port 7489 which is forwarded to the container port (7489), the angularjs app inside the container will send back a response with localhost:7489 and hence the connection is refused and the endless circling. Here’s a screenshot of the error:


#14

This is resolved. I’ll provide an update next week.


#15

Although Eric’s approach may appear to work, WE STRONGLY ADVISE AGAINST IT. Such configurations are likely to expose sensitive data.

Follow the setup instructions and run CE locally, as it was designed.